Welcome to the Atrix Forum - Motorola Atrix Forum.

Register ButtonIf this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

Fastboot help

This is a discussion on Fastboot help within the Rescue Squad forums, part of the Motorola Atrix Support Forum category; I'm in limbo. I tried updating to neutrino 2.8 and i tried to flash it and got stuck in a boot loop. so i followed ...

+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Like Tree3Likes

Thread: Fastboot help

  1. #1
    Junior Member
    Member #
    11423
    Join Date
    Mar 2012
    Posts
    11
    Liked
    3 times

    Fastboot help

    I'm in limbo. I tried updating to neutrino 2.8 and i tried to flash it and got stuck in a boot loop. so i followed the instructions from my last post. from das8nt which were as follows

    I know it sucks, but it sounds like it's time to start fresh.

    You should use fastboot to wipe everything and reinstall.

    Make sure everything you want is on your SD Card.

    First, erase the recovery, then flash a new recovery via fastboot; the recovery should be in the fastboot directory on your PC.

    fastboot erase recovery

    fastboot flash recovery nameofrecovery.img

    fastboot -w

    fastboot erase boot

    fastboot erase preinstall

    fastboot erase system

    fastboot reboot recovery


    That will wipe everything and reboot you into the repaired recovery to install the fresh rom.

    Sent from my MB860 using Tapatalk 2




    however after i wiped the recovery and tried to flash the new recovery it sticks on waiting for devices and i cant do anything with it now and now i cant flash the rom or get into recovery and fastboot isnt communicating properly for some reason. please help me.
    it will say error cannot load recovery
    or
    waiting on device

    i can wipe just not push
    Last edited by thandlovsky; 06-03-2012 at 03:45 PM.

  2. #2
    Senior Member
    Member #
    12844
    Join Date
    May 2012
    Posts
    291
    Twitter
    @Djedgarftw
    Liked
    26 times
    Did you make sure to have it in debugging mode?

    Sent from my MB860 using Tapatalk 2
    Atrix Nottach Trix 4G 1.30

  3. #3
    Junior Member
    Member #
    11423
    Join Date
    Mar 2012
    Posts
    11
    Liked
    3 times
    I have it in fastboot?

  4. #4
    Junior Member
    Member #
    11423
    Join Date
    Mar 2012
    Posts
    11
    Liked
    3 times
    I have it figured out to the point where now i try to flash the recovery and it hangs at
    Waiting for Device

    I tried everything i can think of
    reboot
    Re-install drivers
    re download file

  5. #5
    Super Moderator/RS
    Member #
    7
    Join Date
    Jan 2011
    Location
    Florida Panhandle
    Posts
    11,157
    Twitter
    @das8nt
    Liked
    1281 times
    With the phone showing Starting fastboot protocol, what to you get with "fastboot devices"?

    What is the response when you erase recovery?

    Can you grab a screenshot of your command window after running the devices, erase and flash commands?

    Sent from my rooted Atrix 2 via Tapatalk


    AtrixForums.com : My Anti-Drug : Above the iNfluence


  6. #6
    Junior Member
    Member #
    11423
    Join Date
    Mar 2012
    Posts
    11
    Liked
    3 times
    Attachment 6967



    If image is too small I can Email it to you or try and past it somewhere

  7. #7
    Super Moderator/RS
    Member #
    7
    Join Date
    Jan 2011
    Location
    Florida Panhandle
    Posts
    11,157
    Twitter
    @das8nt
    Liked
    1281 times
    Quote Originally Posted by thandlovsky View Post
    Attachment 6967



    If image is too small I can Email it to you or try and past it somewhere
    For some reason the attached picture isn't showing up at all for me. You can send it to me at my username at gmail and I'll get it posted in case others might be able to weigh in on it.


    AtrixForums.com : My Anti-Drug : Above the iNfluence


  8. #8
    Junior Member
    Member #
    11423
    Join Date
    Mar 2012
    Posts
    11
    Liked
    3 times
    email has been sent

  9. #9
    Super Moderator/RS
    Member #
    7
    Join Date
    Jan 2011
    Location
    Florida Panhandle
    Posts
    11,157
    Twitter
    @das8nt
    Liked
    1281 times
    Got the email and pic. Thanks.

    Very odd indeed. First, a few prelim questions:

    1. At any time did you try to flash a stock SBF file to try to recover?

    2. If not, and for a different reason, would you be willing to try?

    3. Are you using a OEM supplied, or high-quality, USB cable and a fully powered USB port? (not a front port on a desktop)


    If all else fails, we may need to look at returning to stock with a SBF and then "re-unlocking" and moving forward from there. The screenshot shows user data being wiped, which doesn't require the bootloader being unlocked, but flashing a new recovery does. At the very least, you may try re-flashing the unlocker file (pudding) and see if fastboot will proceed from there.
    ROCer likes this.


    AtrixForums.com : My Anti-Drug : Above the iNfluence


  10. #10
    Junior Member
    Member #
    11423
    Join Date
    Mar 2012
    Posts
    11
    Liked
    3 times
    got it!

    i'm not comfortable with sbf files and i dont know much about them, but i am comfortable with ubuntu and thats how i solved my problem.
    set up all the neccasry files on my ubuntu partition and it worked like a charm. just glad i dont have to spend the 550 for a new phone.
    Thank you again for all your help das8nt.
    ROCer and das8nt like this.


 

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Similar Threads

  1. Where can I download moto-fastboot?
    By mugabuga in forum Motorola Atrix Help
    Replies: 1
    Last Post: 03-21-2012, 05:27 PM
  2. Alternate Factory Reset (fastboot)
    By Condor97 in forum Motorola Atrix Hacks
    Replies: 4
    Last Post: 02-02-2012, 05:22 AM
  3. Replies: 0
    Last Post: 12-04-2011, 11:46 AM
  4. [ROOT] 2.3.4 using fastboot
    By TheKaiser in forum Motorola Atrix Hacks
    Replies: 6
    Last Post: 07-26-2011, 10:49 PM
  5. Stuck at Fastboot Protocol Support
    By serialfish in forum Motorola Atrix Help
    Replies: 1
    Last Post: 04-16-2011, 01:52 AM

Search tags for this page

atrix 4g fastboot

,

atrix 4g fastboot waiting for device

,
atrix fastboot drivers
,

atrix fastboot waiting for device

,

fastboot erase recovery waiting for device

,
fastboot help
,

fastboot waiting for device

,
fastboot waiting for device atrix
,

fastboot wipe

,
moto-fastboot atrix 2 waiting for device
,
moto-fastboot erase recovery waiting for device
,
motorola atrix 2 waiting for device
,

motorola atrix fastboot drivers

,
motorola atrix stuck on fastboot
,
waiting for device fastboot atrix 4g
Click on a term to search for related topics.